Universal Access To All Knowledge
Home Donate | Store | Blog | FAQ | Jobs | Volunteer Positions | Contact | Bios | Forums | Projects | Terms, Privacy, & Copyright
Search: Advanced Search
Anonymous User (login or join us)
Upload

Reply to this post | Go Back
View Post [edit]

Poster: Administrator, Curator, or Staffseedpress Date: Nov 16, 2008 6:30pm
Forum: ourmedia Subject: Noobie having trouble

First, I can't seem to find a users' forum on Ourmedia site itself. Somehow I stumbled in to this one using Google. Is there another user's forum?

Second, I'm a fairly experienced net user at various forums and social networks; I appreciate what Internet archive and Ourmedia are doing. But, I have to say, I've had more trouble figuring out how to use the Ourmedia site than I've ever had anywhere else on the net. Maybe it's just me.

Currently I'm waiting--almost 48 hours now--for a jpg I uploaded to actually display on the provided link. It's just going to be unusable for me if this is typical.

Another thing: the front page of Ourmedia has a blog, Community Talk, but when I post it goes off into the ozone. I can find no search function for that blog nor for this forum here.

Any guidance would be greatly appreciated. What I really need is a good Ourmedia users forum with a search function so I can try to troubleshoot my problems before posting stuff.

Reply to this post
Reply [edit]

Poster: Administrator, Curator, or StaffTrashed_Tapes Date: Nov 16, 2008 9:35pm
Forum: ourmedia Subject: Re: Noobie having trouble

http://www.archive.org/iathreads/forum-display.php?forum=ourmedia

Not alot of help but it is the forum you seem to be looking for.